Thursday, May 5, 2011

Solving R error "tar: Failed to set default locale" in Mac OS X

write the following in terminal

defaults write org.R-project.R force.LANG en_US.UTF-8

and restart R

30 comments:

Robert said...

hey.. that didnt help :( It just came up with "Error: unexpected symbol"

espry said...

Thanks! That worked great.

Unknown said...

it works TY

Tekie said...

Perfect! Thank you very much.

AntiDestiny said...

Thank you so much.

Sanjay Antony-Babu said...

Brilliant. Thanks!

Unknown said...

Thanks :) It's great stuff

Dani Nedal said...

Thanks!

Unknown said...

Thanks

Unknown said...

How do I open Terminal?

Unknown said...

Ups, it was in launchpad, Utilities, Terminal. And it worked, thanks :-)

Z said...

Legend, thank you!

Unknown said...

So after I've typed this in and restarted, the whole problem is sorted or do I have re-install the packages?

Unknown said...

Thanks!

Vivek Belhekar said...

Works very well, thanks...!

Daniel said...

Awesome!!

Unknown said...

Thanks!

Praneet Marathe said...

Thanks !

Unknown said...

Thanks!

Fabricera said...

Yes!!! Thanks!

Unknown said...

thank you so much!

Abisurd said...

Worked for me. Thanks

Unknown said...

Great! Thanks

Unknown said...

Thanks!

Artemis said...

You have to type that in the system terminal, not in R

Unknown said...

Thank you

MisCharlotte said...

wow, great, thanks! and what does that actually mean?

Pleiades said...

Great.... that's works, thanks....

Unknown said...

Thanks!

Saeba said...

I wrote defaults write org.R-project.R force.LANG en_US.UTF-8 in the Terminal. but that doesn't work for me. Please help

> install.packages("twitteR")
trying URL 'https://cran.rstudio.com/bin/macosx/mavericks/contrib/3.3/twitteR_1.1.9.tgz'
Content type 'application/x-gzip' length 446644 bytes (436 KB)
==================================================
downloaded 436 KB

tar: Failed to set default locale